Navegador incompatible

Los navegadores más antiguos, como el de Android o Internet Explorer 10 y anteriores no son compatibles con las nuevas necesidades técnicas de MyAlbum de una interfaz de usuario rápida y sin problemas. En esos casos se recomienda que utilices el navegador web gratuito 'Google Chrome'. Este navegador es compatible con casi cualquier dispositivo y se mantiene actualizado automáticamente día a día.

También puedes optar por actualizar tu navegador actual:

Actualización Safari: https://support.apple.com/en-en/HT201541
Actualización IE: https://www.microsoft.com/en-us/download/internet-explorer.aspx
Actualización Firefox: https://support.mozilla.org/en-US/kb/update-firefox-latest-version
Actualización Chrome: https://support.google.com/chrome/answer/95414?hl=en
Útil? | No